Konfigurasi Routing OSPF Cisco Packet Tracer

Open Shortest Path First (OSPF)

OSPF (Open Shortest Path First) merupakan sebuah protokol routing otomatis (Dynamic Routing) yang mampu menjaga, mengatur dan mendistribusikan informasi routing antar network mengikuti setiap perubahan jaringan secara dinamis.

Pada OSPF dikenal sebuah istilah Autonomos System (AS) yaitu sebuah gabungan dari beberapa jaringan yang sifatnya routing dan memiliki kesamaan metode serta policy pengaturan network, yang semuanya dapat dikendalikan oleh network administrator. Dan memang kebanyakan fitur ini digunakan untuk management  dalam jaringan dengan skala yang sangat besar. Oleh karena itu, untuk mempermudah penambahan informasi routing dan meminimalisir kesalahan distribusi informasi routing, maka OSPF bisa menjadi sebuah solusi.

OSPF termasuk dalam kategori IGP (Interior Gateway Protocol) yang memiliki kemampuan Link-State dan Algoritma Djikstra yang jauh lebih efesien dibandingkan protokol IGP yang lain.

Konfigurasi Routing OSPF

Untuk contoh konfigurasinya, pertama buatlah topologinya terlebih dahulu. Berikut contohnya.

Keterangan :

  • Kabel yang digunakan untuk menghubungkan router dengan router yaitu kabel Cross, sedangkan untuk menghubungkan router dengan switch dan switch dengan PC memakai kabel Straight.

Berikut tabel pengalamatan IP Address agar lebih jelas.

Setelah mempelajari tabel pengalamatan di atas, langsung saja kita ke konfigurasinya.

Untuk langkah awalnya kita konfigurasikan terlebih dahulu IP untuk router nya, yang nantinya juga digunakan sebagai gateway.

Pertama konfigurasi Router 0 CLI.

Caranya klik pada Router 0 >> CLI >> lalu konfigurasikan seperti berikut.

Router>en
Router#configure terminal
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fa1/0
Router(config-if)#ip address 192.168.1.5 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit

Kemudian lanjut konfigurasi Router 1 CLI.

Untuk caranya sama seperti diatas, klik pada Router 1 >> CLI >> lalu konfigurasikan seperti berikut.

Router>enable
Router#configure terminal
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.1.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fa1/0
Router(config-if)#ip address 192.168.1.9 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit

Setelah memberikan IP pada setiap router, langsung saja kita masuk ke konfigurasi routing OSPF- nya. Roting OSPF sendiri memiliki langkah-langkah penting dalam konfigurasinya yaitu mengaktifkan mengaktifkan routing OSPF pada router, kemudian mengadvertise network yang terhubung secara langsung dengan router.

Perintah untuk konfigurasi routing OSPF.

#router ospf [process_id]

*Process id pada setiap router tidak harus selalu sama

#network [network_address] [wildcard_mask] [area]

*Network address >> isikan jaringan yang terhubung langsung dengan router.

*Wilcard mask >> kumpulan 32 bit yang digunakan untuk mengenali alamat IP.

Cara untuk menghitung wildcard mask sebenarnya cukup mudah. berikut contohnya.

IP : 192.168.1.0/25  subnet : 255.255.255.0

perhitungan → subnet : 255.255.255.0 dirubah menjadi bit → 11111111.11111111.11111111.00000000

wildcard masknya adalah kebalikan dari tiap bit-bit tersebut.

wilcard → 00000000.00000000.00000000.11111111 = 0.0.0.255

atau bisa juga dengan cara mudahnya yaitu tiap-tiap subnet masknya dikurang dengan 255. contohnya

IP : 192.168.1.0/30 subnet : 255.255.255.252

wildcard mask = 0.0.0.3

Agar lebih jelas perhatikan konfigurasi OSPF berikut.

Router 0

Router>enable
Router#configure terminal
Router(config)#router ospf 1
Router(config-router)#network 192.168.1.0 0.0.0.3 area 0
Router(config-router)#network 192.168.1.4 0.0.0.3 area 0

 
Router 1
Router>enable
Router#configure terminal
Router(config)#router ospf 2
Router(config-router)#network 192.168.1.0 0.0.0.3 area 0
Router(config-router)#network 192.168.1.8 0.0.0.3 area 0

 
Selanjutnya konfigurasikan setiap PC dengan IP Address yang terdapat di tabel di atas dengan cara klik pada PC >> Desktop >> IP Configuration.

PC 1 :
IP Address                  : 192.168.1.6
Subnet Mask               : 255.255.255.252
Default Gateway        : 192.168.1.5

PC 2 :
IP Address                  : 192.168.1.10
Subnet Mask               : 255.255.255.252
Default Gateway        : 192.168.1.9

Terakhir untuk mengujinya kita bisa coba test ping dari setiap PC 1 ke PC 2.

Caranya klik PC >> Desktop >> Command Prompt.

Berikut contoh ping dari PC1 ke PC2.

Jika berhasil akan tampil seperti gambar di atas.

Nah, sekian tutorialnya untuk kali ini, semoga bermanfaat bagi teman-teman semua.

lihat juga :

Konfigurasi Routing RIP di Cisco Packet Tracer

Konfigurasi Routing Static di Cisco Packet Tracer

Membuat Jaringan Client-Server Menggunakan Cisco Packet Tracer

konfigurasi Web server Cisco Packet Tracer

Konfigurasi DNS Server Cisco Packet Tracer

Leave a Comment